Open Discussion

Expand all | Collapse all

Any idea ? ERROR main com.backup42.service.CPService

  • 1.  Any idea ? ERROR main com.backup42.service.CPService

    Posted 08-02-2019 02:54
    Hi,

    I'm experiencing start/stop issue of Code42 CrashPlan service on linux.

    The problem is: The service ERROR main com.backup42.service.CPService start and stop automaticly in a seconde.

    It seen to be because of:

    [07.30.19 14:20:51.421 ERROR main com.backup42.service.CPService] Error starting up, com.code42.exception.DebugRuntimeException: Unable to persist ServiceModel, modelFilename=/usr/local/crashplan/conf/service.model, byteCount=null
    STACKTRACE:: com.code42.exception.DebugRuntimeException: Unable to persist ServiceModel, modelFilename=/usr/local/crashplan/conf/service.model, byteCount=null
    at com.backup42.service.model.ServiceModel.save(ServiceModel.java:351)
    at com.backup42.service.CPService.loadModel(CPService.java:1496)
    at com.backup42.service.CPService.start(CPService.java:493)
    at com.backup42.service.CPService.main(CPService.java:1842)
    Caused by: java.lang.UnsatisfiedLinkError: Unable to load library 'netty_tcnative': Native library (linux-x86-64/libnetty_tcnative.so) not found in resource path ([file:/usr/local/crashplan/lib/com.backup42.desktop.jar, file:/usr/local/crashplan/lang/])

    ------------------------------
    Best regards,
    Moustapha Kourouma
    Engineer
    Rennes
    ------------------------------


  • 2.  RE: Any idea ? ERROR main com.backup42.service.CPService

    Posted 08-05-2019 07:52
    Hi Moustapha,

    I checked in with someone on our support team, and this error could be caused by variety of issues. If you don't get a reply here that helps you, I recommend filing a ticket with our support team so that they can help you diagnose and fix the problem: gethelp.code42.com.

    Beth

    ------------------------------
    Beth Bornhoeft
    Code42
    ------------------------------



  • 3.  RE: Any idea ? ERROR main com.backup42.service.CPService

    Posted 08-06-2019 08:07
    Hi Beth,

    Thanks you !

    I discussed with one of your colleague.

    They advised me to upgrade our server and clients to 7.0.0. They know the issue and the available solution is to upgrade the server and the clients.

    Best regards,

    ------------------------------
    Moustapha Kourouma
    Ingeener
    Rennes
    ------------------------------