Open Discussion

Expand all | Collapse all

Question about backup speed

  • 1.  Question about backup speed

    Posted 02-23-2018 07:24
    Hello, I've been a CrashPlan PROe user for several years now, and generally, I love it.

    There's one little detail I've noticed about how it works that I was hoping to get more understanding about, and ideally see if there is a way to change it.

    When a larger backup is running, the speed of the upload is consistently 3-4x faster if the CrashPlan PROe UI is open and has focus.  There are situations where speed matters, and it would be really nice if there was a way to get that "maximum" upload speed without the app having focus.

    If you want to take this to the extreme, this behavior is a bit of a security issue, as it encourages me to leave my computer unlocked, as Windows-L, or even just when the screen saver kicks in, also reduce things to the slower speed.

    Does anyone know if there is a setting (pretty sure not in the UI, but maybe hidden registry thing?) to enable full speed uploads even when the app is not open, or at least so it doesn't have to have focus and works while the workstation is locked?

    Incidentally, I am on client version 4.6.1 (1435813200461).

    Thanks!

    ------------------------------
    Jeff Boettcher
    Austin TX
    ------------------------------


  • 2.  RE: Question about backup speed

    Posted 02-23-2018 08:09

    My first question would be the type of hosting for your backup.  Cloud, local or hybrid?

     

    Cliff Goeke

    IT Manager

    Communities Unlimited

    3 Colt Drive

    Fayetteville, AR 72703

    Office 479-443-2700 ex110

    Cell 479-236-1666

     






  • 3.  RE: Question about backup speed

    Posted 02-23-2018 10:25
    Thanks for the follow-up Cliff!

    Full disclosure - I'm in a bit of an intermediary position here.  I'm an end user in our corporate environment, and I had to ask our IT department this question, as I might also need to with some follow-up questions, but I'll do my best.

    In this case, I did hear back and was told we have hybrid hosting.

    ------------------------------
    Jeff Boettcher
    Austin TX
    ------------------------------



  • 4.  RE: Question about backup speed

    Posted 02-23-2018 10:33

    Hybrid is a combination of local and cloud.  Of course anything on the cloud's speed is a function of your internet speed. 

    In your client software there are settings for capping bandwidth on the network etc.  Your IT department may have set these. 

    There was a webinar on setting these.  You might do a search for network settings in the help section.

     

    Cliff Goeke

    IT Manager

    Communities Unlimited

    3 Colt Drive

    Fayetteville, AR 72703

    Office 479-443-2700 ex110

    Cell 479-236-1666

     






  • 5.  RE: Question about backup speed

    Posted 02-23-2018 11:02
    Thanks Cliff, though I feel like those settings shouldn't be relevant to the behavior I'm seeing.  Nothing about the network or back-end storage topology is changing here.  Over the course of a 10 minute period, I can open and click on the client UI (to give it focus) and watch the upload speed consistently increase, up to a cap.  If I click on any other application, even with the UI still open, but just no longer in focus, the speed drops from that cap by a factor of 3 - 4.

    ------------------------------
    Jeff Boettcher
    Austin TX
    ------------------------------



  • 6.  RE: Question about backup speed

    Posted 02-26-2018 09:41
    Jeff,

    Have you tried adjusting the % CPU options in the Device Backup Settings? By default it's set to use 80% CPU when the user is not present and 20% CPU when the user is. This sounds a lot like the speed difference you are seeing between with focus and without (4x). Perhaps the system is using more CPU when it has focus (80%) and less when it doesn't (20%). Adjusting these numbers up or down, or just making them equal, and checking the speeds again might prove this out for you.

    ------------------------------
    Wayne Lewis
    MIT Lincoln Laboratory
    Lexington, MA, United States
    ------------------------------



  • 7.  RE: Question about backup speed

    Posted 02-27-2018 08:58
    Thanks Wayne!  Yeah, I've seen some of those settings, and given how they are labeled, they didn't seem like they would address the behavior I'm seeing.  That said, I work in software and understand the way UIs get presented to the user don't always align with how the underlying code works.  ;)  I'll try playing around with those when I have the next larger set of new files to backup, and post my findings.

    ------------------------------
    Jeff Boettcher
    Austin TX
    ------------------------------



  • 8.  RE: Question about backup speed

    Posted 03-15-2018 07:09
    My initial findings are that I set both CPU settings (while user is away, while user is present) to 80 percent, and that seems to have resolved my issue.  That is, after doing so, the CrashPlan PROe app losing focus doesn't seem to have any effect on backup speed.  Thanks for the suggestion Wayne!  I haven't experimented with the effect of setting both to the same lower number, etc, but haven't noticed any impact to usability of my computer with it set at 80, so while kind of curious, to be honest, I don't have a lot of motivation to experiment further with this, heh.

    ------------------------------
    Jeff Boettcher
    Austin TX
    ------------------------------



  • 9.  RE: Question about backup speed

    Posted 03-19-2018 07:34
    One additional unfortunate data point - While changing both low and high CPU settings to 80 cause backups to be the same faster speed regardless of whether the CrashPlan PROe app is open and has focus, when the screen blanks due to inactivity, or immediately on use of Windows-L to lock the workstation, backups still get slower like they used to.

    ------------------------------
    Jeff Boettcher
    Austin TX
    ------------------------------